在header信息中隐藏php信息

2014-4-27 liyangweb.com 李杨 PHP

   在php渲染的网页header信息中,会包含php的版本号信息,比如: X-Powered-by: php/5.3.3,这有些不安全,有些黑客可能采用扫描的方式,批量寻找低版本的php服务器,利用php漏洞(比如最近流行的hash冲突)来攻击服务器。

    php.ini中有一个选项可以控制是否暴露这个信息,那就是:

     expose_php = On

     默认值是On,改成Off之后,就不会显示php版本信息啦。

    或者在php-fpm的pool配置文件中设置:

    

     php_admin_flag[expose_php] = off

标签: PHP

发表评论:

Powered by emlog 冀ICP备13011830号-1