libxml2和libxml2-dev的区别

2018-11-14 liyangweb.com 李杨 服务器

在我们编译安装PHP时,经常会报出类似的错误:

configure: error: libxml2 not found. Please check your libxml2 installation.

字面意思很容易理解,是说没找到libxml2,但是如果我们搜索一下系统,会发现libxml2是安装过的,而且我们再使用包管理工具(apt-get/yum)来安装,会提示libxml2已安装:

libxml2 is already the newest version.

这是为什么呢?

我们来搜索一下软件源中所包含libxml2字样的软件包(加上 ‘| grep libxml2’是为了关键字可以高亮显示):

apt-cache search libxml2 | grep libxml2

在密密麻麻的搜索结果中,发现了这样一个软件:

libxml2-dev - Development files for the GNOME XML library

包名后面多了一个-dev,我们把这个包装上试试,结果不卖关子了,自然是OK了。

那么同一个包,后面带不带-dev有什么区别呢?

libxml2就是一个普通包,libxml2-dev是开发包。

如果你安装基于libxml2开发的软件,那么你只需要安装libxml2就可以了,如果你需要编译使用了libxml2的软件,那就需要安装libxml2-dev。

评论:

网站建设
约 14 小时前
来看看

发表评论:

Powered by emlog 冀ICP备13011830号-1